Skip to content
Xubuntu freeze on l...
Clear all

Xubuntu freeze on lightdm login after upgrade to 22.04/22.10

1 Posts
1 Users
Illustrious Member
Joined: 6 months ago
Posts: 72614
Topic starter  

I think it's the first time, that I ask a question here, since I found an answer for all previous issues.
I upgraded my xubuntu 20.04 to 22.04 (and then on commandline to 22.10, because I hoped, the problem will solve itself. But it remains).
I can login from a text terminal but never more from lightdm. I enter my credentials, and then I see the background-image, the mouse-pointer can be moved, but nothing else is displayed. Restarting lightdm.service lets login me again, but the behavior is the same.
I also tried to switch to gdm3 (like suggested here), but it has the same effect (except the mouse freezes too).
The .xsession-errors has only a few entries:

dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/wolfgang/.Xauthority
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1 looks normal so far, 

also dmesg and syslog dont show any hint. Where could I continue the research?

This is the Xorg.0.log (Part1):

[   232.736] 
X.Org X Server
X Protocol Version 11, Revision 0
[   232.736] Current Operating System: Linux merlin 5.19.0-35-generic #36-Ubuntu SMP PREEMPT_DYNAMIC Fri Feb 3 18:36:56 UTC 2023 x86_64
[   232.736] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.19.0-35-generic root=UUID=696192c7-692f-4e04-9022-fd082eef9987 ro vga=0x31f
[   232.736] xorg-server 2:21.1.4-2ubuntu1.6 (For technical support please see  
[   232.736] Current version of pixman: 0.40.0
[   232.736]    Before reporting problems, check 
    to make sure that you have the latest version.
[   232.736] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   232.736] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 21 22:05:48 2023
[   232.737] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   232.737] (==) No Layout section.  Using the first Screen section.
[   232.737] (==) No screen section available. Using defaults.
[   232.737] (**) |-->Screen "Default Screen Section" (0)
[   232.737] (**) |   |-->Monitor "<default monitor>"
[   232.738] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   232.738] (==) Automatically adding devices
[   232.738] (==) Automatically enabling devices
[   232.738] (==) Automatically adding GPU devices
[   232.738] (==) Automatically binding GPU devices
[   232.738] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   232.738] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   232.738]    Entry deleted from font path.
[   232.738] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   232.738]    Entry deleted from font path.
[   232.738] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   232.738]    Entry deleted from font path.
[   232.738] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   232.738]    Entry deleted from font path.
[   232.738] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   232.738]    Entry deleted from font path.
[   232.738] (==) FontPath set to:
[   232.738] (==) ModulePath set to "/usr/lib/xorg/modules"
[   232.738] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   232.738] (II) Loader magic: 0x5570cf6f1020
[   232.738] (II) Module ABI versions:
[   232.738]    X.Org ANSI C Emulation: 0.4
[   232.738]    X.Org Video Driver: 25.2
[   232.738]    X.Org XInput driver : 24.4
[   232.738]    X.Org Server Extension : 10.0
[   232.739] (++) using VT number 7

[   232.739] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   232.740] (II) xfree86: Adding drm device (/dev/dri/card0)
[   232.740] (II) Platform probe for /sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0/drm/card0
[   232.744] (--) PCI:*(2@0:0:0) 1002:68f9:174b:e127 rev 0, Mem @ 0xe0000000/268435456, 0xfbfe0000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[   232.744] (II) LoadModule: "glx"
[   232.744] (II) Loading /usr/lib/xorg/modules/extensions/
[   232.745] (II) Module glx: vendor="X.Org Foundation"
[   232.745]    compiled for, module version = 1.0.0
[   232.745]    ABI class: X.Org Server Extension, version 10.0
[   232.745] (II) Applying OutputClass "Radeon" to /dev/dri/card0
[   232.745]    loading driver: radeon
[   232.745] (==) Matched radeon as autoconfigured driver 0
[   232.745] (==) Matched ati as autoconfigured driver 1
[   232.745] (==) Matched modesetting as autoconfigured driver 2
[   232.745] (==) Matched fbdev as autoconfigured driver 3
[   232.745] (==) Matched vesa as autoconfigured driver 4
[   232.745] (==) Assigned the driver to the xf86ConfigLayout
[   232.745] (II) LoadModule: "radeon"
[   232.745] (II) Loading /usr/lib/xorg/modules/drivers/
[   232.746] (II) Module radeon: vendor="X.Org Foundation"
[   232.746]    compiled for, module version = 19.1.0
[   232.746]    Module class: X.Org Video Driver
[   232.746]    ABI class: X.Org Video Driver, version 25.2
[   232.746] (II) LoadModule: "ati"
[   232.746] (II) Loading /usr/lib/xorg/modules/drivers/
[   232.746] (II) Module ati: vendor="X.Org Foundation"
[   232.746]    compiled for, module version = 19.1.0
[   232.746]    Module class: X.Org Video Driver
[   232.746]    ABI class: X.Org Video Driver, version 25.2
[   232.746] (II) LoadModule: "modesetting"
[   232.746] (II) Loading /usr/lib/xorg/modules/drivers/
[   232.746] (II) Module modesetting: vendor="X.Org Foundation"
[   232.746]    compiled for, module version = 1.21.1
[   232.746]    Module class: X.Org Video Driver
[   232.746]    ABI class: X.Org Video Driver, version 25.2
[   232.746] (II) LoadModule: "fbdev"
[   232.747] (II) Loading /usr/lib/xorg/modules/drivers/
[   232.747] (II) Module fbdev: vendor="X.Org Foundation"
[   232.747]    compiled for, module version = 0.5.0
[   232.747]    Module class: X.Org Video Driver
[   232.747]    ABI class: X.Org Video Driver, version 25.2
[   232.747] (II) LoadModule: "vesa"
[   232.747] (II) Loading /usr/lib/xorg/modules/drivers/
[   232.747] (II) Module vesa: vendor="X.Org Foundation"
[   232.747]    compiled for, module version = 2.5.0
[   232.747]    Module class: X.Org Video Driver
[   232.747]    ABI class: X.Org Video Driver, version 25.2
[   232.747] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
    ATI Radeon Mobility X600 (M24), ATI FireMV 2400,
    ATI Radeon Mobility X300 (M24), ATI FireGL M24 GL,
    ATI Radeon X600 (RV380), ATI FireGL V3200 (RV380),
    ATI Radeon IGP320 (A3), ATI Radeon IGP330/340/350 (A4),
    ATI Radeon 9500, ATI Radeon 9600TX, ATI FireGL Z1, ATI Radeon 9800SE,
    ATI Radeon 9800, ATI FireGL X2, ATI Radeon 9600, ATI Radeon 9600SE,
    ATI Radeon 9600XT, ATI FireGL T2, ATI Radeon 9650, ATI FireGL RV360,
    ATI Radeon 7000 IGP (A4+), ATI Radeon 8500 AIW,
    ATI Radeon IGP320M (U1), ATI Radeon IGP330M/340M/350M (U2),
    ATI Radeon Mobility 7000 IGP, ATI Radeon 9000/PRO, ATI Radeon 9000,
    ATI Radeon X800 (R420), ATI Radeon X800PRO (R420),
    ATI Radeon X800SE (R420), ATI FireGL X3 (R420),
    ATI Radeon Mobility 9800 (M18), ATI Radeon X800 SE (R420),
    ATI Radeon X800XT (R420), ATI Radeon X800 VE (R420),
    ATI Radeon X850 (R480), ATI Radeon X850 XT (R480),
    ATI Radeon X850 SE (R480), ATI Radeon X850 PRO (R480),
    ATI Radeon X850 XT PE (R480), ATI Radeon Mobility M7,
    ATI Mobility FireGL 7800 M7, ATI Radeon Mobility M6,
    ATI FireGL Mobility 9000 (M9), ATI Radeon Mobility 9000 (M9),
    ATI Radeon 9700 Pro, ATI Radeon 9700/9500Pro, ATI FireGL X1,
    ATI Radeon 9800PRO, ATI Radeon 9800XT,
    ATI Radeon Mobility 9600/9700 (M10/M11),
    ATI Radeon Mobility 9600 (M10), ATI Radeon Mobility 9600 (M11),
    ATI FireGL Mobility T2 (M10), ATI FireGL Mobility T2e (M11),
    ATI Radeon, ATI FireGL 8700/8800, ATI Radeon 8500, ATI Radeon 9100,
    ATI Radeon 7500, ATI Radeon VE/7000, ATI ES1000,
    ATI Radeon Mobility X300 (M22), ATI Radeon Mobility X600 SE (M24C),
    ATI FireGL M22 GL, ATI Radeon X800 (R423), ATI Radeon X800PRO (R423),
    ATI Radeon X800LE (R423), ATI Radeon X800SE (R423),
    ATI Radeon X800 XTP (R430), ATI Radeon X800 XL (R430),
    ATI Radeon X800 SE (R430), ATI Radeon X800 (R430),
    ATI FireGL V7100 (R423), ATI FireGL V5100 (R423),
    ATI FireGL unknown (R423), ATI Mobility FireGL V5000 (M26),
    ATI Mobility Radeon X700 XL (M26), ATI Mobility Radeon X700 (M26),
    ATI Radeon X550XTX, ATI Radeon 9100 IGP (A5),
    ATI Radeon Mobility 9100 IGP (U3), ATI Radeon XPRESS 200,
    ATI Radeon XPRESS 200M, ATI Radeon 9250, ATI Radeon 9200,
    ATI Radeon 9200SE, ATI FireMV 2200, ATI Radeon X300 (RV370),
    ATI Radeon X600 (RV370), ATI Radeon X550 (RV370),
    ATI FireGL V3100 (RV370), ATI FireMV 2200 PCIE (RV370),
    ATI Radeon Mobility 9200 (M9+), ATI Mobility Radeon X800 XT (M28),
    ATI Mobility FireGL V5100 (M28), ATI Mobility Radeon X800 (M28),
    ATI Radeon X850, ATI unknown Radeon / FireGL (R480),
    ATI Radeon X800XT (R423), ATI FireGL V5000 (RV410),
    ATI Radeon X700 XT (RV410), ATI Radeon X700 PRO (RV410),
    ATI Radeon X700 SE (RV410), ATI Radeon X700 (RV410),
    ATI Radeon X1800, ATI Mobility Radeon X1800 XT,
    ATI Mobility Radeon X1800, ATI Mobility FireGL V7200,
    ATI FireGL V7200, ATI FireGL V5300, ATI Mobility FireGL V7100,
    ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
    ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
    ATI Mobility Radeon X1400, ATI Radeon X1550 64-bit,
    ATI Mobility Radeon X1300, ATI Radeon X1300, ATI FireGL V3300,
    ATI FireGL V3350, ATI Mobility Radeon X1450,
    ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
    ATI FireMV 2250, ATI Radeon X1650, ATI Mobility FireGL V5200,
    ATI Mobility Radeon X1600, ATI Radeon X1300 XT/X1600 Pro,
    ATI FireGL V3400, ATI Mobility FireGL V5250,
    ATI Mobility Radeon X1700, ATI Mobility Radeon X1700 XT,
    ATI FireGL V5200, ATI Radeon X2300HD, ATI Mobility Radeon HD 2300,
    ATI Radeon X1950, ATI Radeon X1900, ATI AMD Stream Processor,
    ATI RV560, ATI Mobility Radeon X1900, ATI Radeon X1950 GT, ATI RV570,
    ATI FireGL V7400, ATI Radeon 9100 PRO IGP,
    ATI Radeon Mobility 9200 IGP, ATI Radeon X1200, ATI RS740,
    ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro,
    ATI Radeon HD 2900 GT, ATI FireGL V8650, ATI FireGL V8600,
    ATI FireGL V7600, ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
    ATI Radeon HD 4850 x2, ATI FirePro V8750 (FireGL),
    ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,
    ATI Mobility RADEON HD 4850 X2, ATI FirePro RV770,
    AMD FireStream 9270, AMD FireStream 9250, ATI FirePro V8700 (FireGL),
    ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
    ATI FirePro M7750, ATI M98, ATI Mobility Radeon HD 4650,
    ATI Radeon RV730 (AGP), ATI Mobility Radeon HD 4670,
    ATI FirePro M5750, ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
    ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
    ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
    ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
    ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
    ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI RV610,
    ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,
    ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI Radeon HD 2350,
    ATI Mobility Radeon HD 2400 XT, ATI Mobility Radeon HD 2400,
    ATI RADEON E2400, ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
    ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
    ATI Mobility Radeon HD 3850 X2, ATI Mobility Radeon HD 3870,
    ATI Mobility Radeon HD 3870 X2, ATI Radeon HD3870 X2,
    ATI FireGL V7700, ATI Radeon HD3690, AMD Firestream 9170,
    ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon HD 4350,
    ATI Mobility Radeon 4300 Series, ATI Mobility Radeon 4500 Series,
    ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
    ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
    ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
    ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
    ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
    ATI FireGL V3600, ATI Radeon HD 2600 LE,
    ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
    ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
    ATI Radeon HD 3450, ATI Radeon HD 3430, ATI FirePro V3700,
    ATI FireMV 2450, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP,
    ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,
    ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
    ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
    ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
    ATI Radeon HD 3300 Graphics, ATI Radeon 3000 Graphics, SUMO, SUMO2,
    ATI Radeon HD 4200, ATI Radeon 4100, ATI Mobility Radeon HD 4200,
    ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
    AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
    AMD Radeon HD 6300 Series Graphics,
    AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
    ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
    AMD Firestream 9350, ATI Radeon HD 5800 Series,
    ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
    ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
    ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
    ATI Radeon HD 5670, ATI Radeon HD 5570, ATI Radeon HD 5500 Series,
    REDWOOD, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
    ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
    AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
    AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
[   232.749] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   232.749] (II) FBDEV: driver for framebuffer: fbdev
[   232.749] (II) VESA: driver for VESA chipsets: vesa
[   232.758] (II) [KMS] Kernel modesetting enabled.
[   232.758] (WW) Falling back to old probe method for modesetting
[   232.758] (WW) Falling back to old probe method for fbdev
[   232.758] (II) Loading sub module "fbdevhw"
[   232.758] (II) LoadModule: "fbdevhw"
[   232.759] (II) Loading /usr/lib/xorg/modules/
[   232.759] (II) Module fbdevhw: vendor="X.Org Foundation"
[   232.759]    compiled for, module version = 0.0.2
[   232.759]    ABI class: X.Org Video Driver, version 25.2
[   232.759] (II) RADEON(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   232.759] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[   232.759] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   232.759] (==) RADEON(0): Default visual is TrueColor
[   232.759] (==) RADEON(0): RGB weight 888
[   232.759] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[   232.759] (--) RADEON(0): Chipset: "ATI Radeon HD 5450" (ChipID = 0x68f9)
[   232.759] (II) Loading sub module "fb"
[   232.759] (II) LoadModule: "fb"
[   232.759] (II) Module "fb" already built-in
[   232.759] (II) Loading sub module "dri2"
[   232.759] (II) LoadModule: "dri2"
[   232.759] (II) Module "dri2" already built-in
[   232.829] (II) Loading sub module "glamoregl"
[   232.830] (II) LoadModule: "glamoregl"
[   232.830] (II) Loading /usr/lib/xorg/modules/
[   232.835] (II) Module glamoregl: vendor="X.Org Foundation"
[   232.835]    compiled for, module version = 1.0.1
[   232.835]    ABI class: X.Org ANSI C Emulation, version 0.4
[   232.853] (II) RADEON(0): glamor X acceleration enabled on AMD CEDAR (DRM 2.50.0 / 5.19.0-35-generic, LLVM 15.0.2)
[   232.853] (II) RADEON(0): glamor detected, initialising EGL layer.
[   232.853] (II) RADEON(0): KMS Color Tiling: enabled
[   232.853] (II) RADEON(0): KMS Color Tiling 2D: enabled
[   232.853] (==) RADEON(0): TearFree property default: auto
[   232.853] (II) RADEON(0): KMS Pageflipping: enabled
[   232.870] (II) RADEON(0): Output DVI-0 has no monitor section
[   232.902] (II) RADEON(0): Output DVI-1 has no monitor section
[   232.918] (II) RADEON(0): EDID for output DVI-0
[   232.950] (II) RADEON(0): EDID for output DVI-1
[   232.950] (II) RADEON(0): Manufacturer: SAM  Model: 2b5  Serial#: 1213542964
[   232.950] (II) RADEON(0): Year: 2008  Week: 13
[   232.950] (II) RADEON(0): EDID Version: 1.3
[   232.950] (II) RADEON(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
[   232.950] (II) RADEON(0): Sync:  Separate  Composite  SyncOnGreen
[   232.950] (II) RADEON(0): Max Image Size [cm]: horiz.: 52  vert.: 32
[   232.950] (II) RADEON(0): Gamma: 2.60
[   232.950] (II) RADEON(0): DPMS capabilities: Off; RGB/Color Display
[   232.950] (II) RADEON(0): First detailed timing is preferred mode
[   232.950] (II) RADEON(0): redX: 0.653 redY: 0.337   greenX: 0.295 greenY: 0.607
[   232.950] (II) RADEON(0): blueX: 0.144 blueY: 0.075   whiteX: 0.312 whiteY: 0.329
[   232.950] (II) RADEON(0): Supported established timings:
[   232.950] (II) RADEON(0): 720x400@70Hz
[   232.950] (II) RADEON(0): 640x480@60Hz
[   232.950] (II) RADEON(0): 640x480@67Hz
[   232.950] (II) RADEON(0): 640x480@72Hz
[   232.950] (II) RADEON(0): 640x480@75Hz
[   232.950] (II) RADEON(0): 800x600@56Hz
[   232.950] (II) RADEON(0): 800x600@60Hz
[   232.950] (II) RADEON(0): 800x600@72Hz
[   232.950] (II) RADEON(0): 800x600@75Hz
[   232.950] (II) RADEON(0): 832x624@75Hz
[   232.950] (II) RADEON(0): 1024x768@60Hz
[   232.950] (II) RADEON(0): 1024x768@70Hz
[   232.950] (II) RADEON(0): 1024x768@75Hz
[   232.950] (II) RADEON(0): 1280x1024@75Hz
[   232.950] (II) RADEON(0): 1152x864@75Hz
[   232.950] (II) RADEON(0): Manufacturer's mask: 0
[   232.950] (II) RADEON(0): Supported standard timings:
[   232.950] (II) RADEON(0): #0: hsize: 1600  vsize 1200  refresh: 60  vid: 16553
[   232.950] (II) RADEON(0): #1: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
[   232.950] (II) RADEON(0): #2: hsize: 1280  vsize 960  refresh: 60  vid: 16513
[   232.950] (II) RADEON(0): #3: hsize: 1152  vsize 864  refresh: 75  vid: 20337
[   232.950] (II) RADEON(0): Supported detailed timing:
[   232.950] (II) RADEON(0): clock: 154.0 MHz   Image Size:  518 x 324 mm
[   232.950] (II) RADEON(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
[   232.950] (II) RADEON(0): v_active: 1200  v_sync: 1203  v_sync_end 1209 v_blanking: 1235 v_border: 0
[   232.950] (II) RADEON(0): Ranges: V min: 56 V max: 75 Hz, H min: 30 H max: 81 kHz, PixClock max 175 MHz

Thank you.


Unreplied Posts

is_user_logged_in() undefined at shutdown in plugin context

The function is_user_logged_in() is not available at shutdown (plugin context, not theme).

I want my plugin to run only (1) on front-end pages and (2) when the user is not logged in.

This partially works, but it also runs on Divi builder front-end pages, so I need to add !is_user_logged_in:

if (!is_admin()) {
    add_action('shutdown', function () {
        // Do some ob_start() and PHP_Tidy() stuff...
    }, 0);

Unfortunately changing my conditional to if (!is_admin() && !is_user_logged_in()) fails with:

Uncaught Error: Call to undefined function is_user_logged_in() in...

How can I find the next following line containing a specific string, then append that to the current line? (Notepad++)

I guess I’m trying to do two things using Notepad++:

  1. Find a line containing a comma character, then
  2. Find a subsequent line that contains the word “Proximity”, then copy that entire line, and append it to the current line in #1 above. The line containing “Proximity” could be any number of lines down from the original line.

Here’s a mock up:

“SCOTT, Michael”
“Office Manager”
“Card Number Card Format Disabled”
“0273ADNC PAC Proximity Reader False”
“Random rubbish”
“SCHRUTE, Dwight”
“Card Number Card Format Disabled”
“0897FFRF PAC Proximity Reader False”

Should become:

“SCOTT, Michael ; 0273ADNC PAC Proximity Reader False”
“SCHRUTE, Dwight ; 0897FFRF PAC Proximity Reader False”

I added the semicolon just to help me parse it later. I also want to remove any extra lines other than the line containing the comma (also contains the names), and the “Proximity” line.

Any ideas are appreciated!

Why is a field extension $L:K$ normal if and only if $text{Aut}(L:K)$ acts transitively on the set of homomorphisms $Lto overline{K}$?


According to Wikipedia, given the algebraic extension $L:K$, the following are equivalent:

$a)$ The minimal polynomial over $K$ of every element in $L$ splits in $L$.

$b)$ $text{Aut}(L:K)$ acts transitively on the set of homomorphisms $Lto overline{K}$ where $overline{K}$ is the algebraic closure of $K$.

I have found nothing similar to the above result (equivalence of the conditions) in Stewart’s Galois Theory, and thus I’m wondering why are the conditions above equivalent?


Can connect to Droplet only using root user

I’m trying to set up a Digital Ocean Droplet, and i have created a new user to follow best practices and also so that i can run the code command, because it isn’t allowed as the root user.
I can login using
ssh -i ~/.ssh/id_rsa root@droplet_ip
but running
ssh -i ~/.ssh/id_rsa my_user@droplet_ip
returns my_user@droplet_ip: Permission denied (publickey).
Why is this issue occuring?
I also have managed to change the user after logging in as root using sudo su my_user, but when I try to run code it says
mkdir: cannot create directory ‘’: No such file or directory which is very odd.

Any help will be greatly appreciated 🙂

Using a list in batch file

I need to copy a file if exist to a list of destinations. The Destination contain %variables% . When I run it appears to be taking the literal path as given in the array list.

How can I make it use the variable in the array list?

The lnk and the Shortcut_Locations.txt are located in same folder as script.

@echo off

pushd "%~dp0" 

set source_file=App1.lnk

set destination_list=Shortcut_Locations.txt

for /f "tokens=*" %%I in (%destination_list%) do (
    if exist "%%I" (
        copy /Y "%source_file%" "%%I"


Shortcut_Locations.txt content


Proving set is Borel in $S^{n-1}$


I am reading Mattila’s “Fourier analysis and Hausdorff dimension”, the author leaves as an exercise to prove that the set $S_infty$ is a Borel set. I will now define the set $S_infty$:

Theorem 5.1: Let $Asubsetmathbb{R}^n$ be a Borel set with $text{dim}A=sleq1$. Then for all $tin[0,s]$
$$ text{dim}{ ein S^{n-1} : text{dim}P_e(A)<t }leq n-2+t $$

Where $P_e: mathbb{R}^nto mathbb{R}$, is the proyection $P_e(x) = ecdot x$ for some $ein S^{n-1}$. For the proof the autor takes $sigma<tleq s$ and finds a Borel measure $mu$ with support on $A$ such that $0<mu(A)<infty$ and such that $I_sigma(mu)<infty$, where $I_sigma(mu)$ is the energy defined as

$$ I_sigma(mu) = iint |x-y|^{-sigma},dmu x,dmu y.$$

He then has to prove that

$$S_infty = {ein S^{n-1} : I_sigma(mu_e) =infty}$$

is a Borel set. Where $mu_e(B) = mu(P_e^{-1}(B))$ is the push-forward of $mu$ under $P_e$.

This is what I tried doing:

I_sigma(mu_e) = int_{-infty}^inftyint_{-infty}^infty |x-y|^{-sigma},dmu_ex,dmu_ey &= int_{mathbb{R}^n}int_{mathbb{R}^n} |ecdotxi – ecdotzeta|^{-sigma},dmu xi,dmuzeta \
&= int_{mathbb{R}^n}int_{mathbb{R}^n} |e|^{-sigma}|xi – zeta|^{-sigma},dmuxi,dmuzeta\
&= int_{mathbb{R}^n}int_{mathbb{R}^n} |xi – zeta|^{sigma},dmuxi,dmuzeta\
&= I_sigma(mu),

where I’m using that because $ein S^{n-1}$ then $|e| =1$. But then I get stuck and I do not know how to continue with the calculations, because the set
$${ ein S^{n-1} : I_sigma(mu)=infty }$$
doesn’t make sense to me, maybe my previous calculation is wrong.


Problem with PID – Zabbix Server on Ubuntu (WSL2)

I’m having trouble trying to start Zabbix Server (6.4) on WSL2. When I try the following command:

service zabbix-server restart:

I received the following message:

 * Stopping Zabbix server zabbix_server
No process in pidfile '/var/run/zabbix/' found running; none killed.   [ OK ]
 * Starting Zabbix server zabbix_server   

And Zabbix Server does not start:

service zabbix-server status:

 * zabbix_server is not running

Inside the log file (/var/log/zabbix/zabbix_server.log), is found the follow message repeated several times:

13660:20230417:160028.155 [Z3001] connection to database 'zabbix' failed: [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (13) 

Followed with the message in the end of the file:

13660:20230417:160028.155 database is down: reconnecting in 10 seconds 13660:20230417:160032.344 Got signal [signal:15(SIGTERM),sender_pid:15318,sender_uid:0,reason:0]. Exiting ... 
13660:20230417:160032.344 Zabbix Server stopped. Zabbix 6.4.1 (revision 546e284fd7c).

But I already installed the mysql-server normally, and it is running without any kind of problem.

How can I connect from a mac to a windows?

I have two computers on the same local networks and I have installed OpenSSH Server on the windows and activated the 22 port communication on the windows.

Then in my mac i put

ssh username@ip_of_windows

however, it doesn’t let me connect on terminal. The connection just disappears without any error. What am I missing?

thank you!

Cox’s exercise 5.1 on (eventually) proving ring of integers is a dedekind domain


Note: It seems that $LaTeX$ rendering is very broken, either for my Firefox browser or for the site. Here is an example: $mathfrak{a}_{n} = mathfrak{a}_{n + 1} = cdots$ turns into $mathfrak{a}_{n} = mathfrak{a}_{n + 1} = cdots$. I can’t fix it, so I have rendered it and pasted an image below. Hopefully it will be fixed soon. (I might make a meta post, not sure if that’s the right move).

Update: It seems to be fixed when I submitted the question? It rendered as broken LaTeX (and very slowly, unlike now where it’s instant). I have moved the image to the bottom, in case the problem is occuring for others.

Hi! I am reading Cox’s “Primes of the Form $x^2 + ny^2$“, and am on Chapter 5 (it’s a speedrun from number fields to Hilbert’s class field). I am attempting exercise 5.1, and I have done some parts, so I am both asking for verification for my solution as well as hints for the rest.

Things we have stated:

Proposition 5.3. For a number field $K$

(i) $mathcal{O}_K$ is a subring of $mathbb{C}$ whose field of fractions is $K$.

(ii) $mathcal{O}_K$ is a free $mathbb{Z}$-module of rank $[K : mathbb{Q}]$.

(a) Show that a nonzero ideal $mathfrak{a}$ of $mathcal{O}_K$ contains a nonzero integer $m$. (Hint: …)

My solution: Let $alpha neq 0$ be in $mathfrak{a}$. Of course it is algebraic, so let the monic integer polynomial $f(x) = a_0 + a_1x + cdots + a_{n – 1}x^{n – 1} + x^n$ be its minimal polynomial. Now, $langle alpha rangle subset mathfrak{a}$. In particular, for all integers $i geq 1$, the elements $alpha^i$ are in $mathfrak{a}$. This then means $sum_{i geq 1} a_i alpha^i in mathfrak{a}$, and since $f(alpha) = 0 in mathfrak{a}$, we have $m = a_0 in mathfrak{a}$.

(b) Show that $mathcal{O}_K / mathfrak{a}$ is finite whenever $mathfrak{a}$ is a nonzero ideal of $mathcal{O}_K$. Hint: if $m$ is the integer from (a), consider the surjection $mathcal{O}_K / mmathcal{O}_K to mathcal{O}_K / mathfrak{a}$. Use part (ii) of Proposition 5.3 to compute the order of $mathcal{O}_K / mmathcal{O}_K$.

My Ideas: From above, we know that $langle m rangle subset langle alpha rangle subset mathfrak{a}$, so my intuition tells me that this surjection definitely exists. (In my intuition, everything’s a module / vector space, so this surjection is just a projection map?) However, I don’t know how to explicitly describe it.

To compute $left|mathcal{O}_K / mmathcal{O}_Kright|$, from the proposition above we know that $mathcal{O}_K cong mathbb{Z}^{[K : mathbb{Q}]}$, so $mathcal{O}_K / mmathcal{O}_K$ is just $left(mathbb{Z} / mmathbb{Z}right)^{[K : mathbb{Q}]}$ and the order is $m^{[K : mathbb{Q}]}$. This part makes sense but feels a little hand wavy? Or is it justified as is?

(c) Use (b) to show that every nonzero ideal of $mathcal{O}_K$ is a free $mathbb{Z}$-module of rank $[K : mathbb{Q}]$.

My solution: Fix a nonzero ideal $mathfrak{a} subset mathcal{O}_K$. We know that $mathcal{O}_K / mathfrak{a}$ is finite and $mathcal{O}_K cong mathbb{Z}^{[K : mathbb{Q}]}$, so $mathfrak{a}$ has to be a product of $[K : mathbb{Q}]$ infinite subgroups of $mathbb{Q}$, i.e. $mathfrak{a} cong prod_{i = 1}^{[K : mathbb{Q}]} m_imathbb{Z}$. This is easy to prove by a simple proof by contradiction.

(d) If we have ideals $mathfrak{a}_1 subset mathfrak{a}_2 subset cdots$, show that there is an integer $n$ such that $mathfrak{a}_n = mathfrak{a}_{n + 1} = cdots$. Hint: consider the surjections $mathcal{O}_K / mathfrak{a}_1 to mathcal{O}_K / mathfrak{a}_2 to cdots$, and use (b).

My solution: Again, my intuition tells me the surjections $mathcal{O}_K / mathfrak{a}_i to mathcal{O}_K / mathfrak{a}_{i + 1}$ exists, but I don’t know how to construct them. Anyways, I claim that if $mathfrak{a}_i neq mathfrak{a}_{i + 1}$, then $left|mathcal{O}_K / mathfrak{a}_{i + 1}right| < left|mathcal{O}_K / mathfrak{a}_iright|$. This holds because for $alpha in mathfrak{a}_{i + 1} setminus mathfrak{a}_i$ is a nonzero element in the kernel of the surjection. Since the quotients are finite, it must eventually stop and hence there are no infinite ascending chains.

(e) Use (b) to show that a nonzero prime ideal of $mathcal{O}_K$ is maximal.

My ideas: Let $mathfrak{a}$ be a prime ideal of $mathcal{O}_K$, and suppose that $mathfrak{a} supset mathfrak{b}$ (i.e. $mathfrak{a}$ is not maximal), which gives $mathcal{O}_K / mathfrak{b} subset mathcal{O}_K / mathfrak{a}$. Thinking about everything as $mathbb{Z}$-modules, we can write $mathcal{O}_K cong prod_{i = 1}^{[K : mathbb{Q}]} mathbb{Z}$ as ordered coordinates, and similar that $mathcal{O}_K / mathfrak{b} cong prod_{i = 1}^{[K : mathbb{Q}]} mathbb{Z} / m_i mathbb{Z}$ and $mathcal{O}_K / mathfrak{a} cong prod_{i = 1}^{[K : mathbb{Q}]} mathbb{Z} / n_i mathbb{Z}$. By the inclusion, we know that $m_i mid n_i$, and for at least one $j$, $m_j neq n_j$. However, for such $j$ we have that $n_j = m_j cdot left(frac{n_j}{m_j}right)$ i.e. $mathbb{Z} / n_j mathbb{Z}$ is not an integral domain, and hence the product ring is not an integral domain, which means $mathfrak{a}$ is not prime.

For you for your help in advance!

enter image description here